Firefox Download Center


Download and Upgrade

Firefox - Older Operating Systems

Because Firefox is still the ITWorkshop's recommended browser in most cases. However, Mozilla have chosen to drop support for older operating systems.

The minimum requirements are now Windows XP or OS X 10.6 (Snow Leopard). Power PC users (10.4 and 10.5) can use tenfourfox.

We recommend users of older systems consider moving to Opera as the versions of Firefox that work become unsupported (and therefore any newly discovered vulnerabilities are not fixed).

Opera 10.5.8 works on OS X 10.5 (Loepard), Opera 10 works on OS X 10.3 (Panther) and Windows 98 (and possibly even Windows 95). Opera 9 works on OS X 10.2 (Jaguar) and Windows 95.

The version of opera for mobile phones - Opera Mini - is very good and can synchronise with full size Opera.

PDF

Due to the increasing "bloat" of adobe acrobat reader, vulnerabilities are happening in a system that should not be able to support them. (PDFs are documents not programs).

We consider disabling javascript in the reader preferences a good precaution. We also feel that foxit reader is a better alternative for many users.

IT Workshop (UK) Ltd. Copyright 2006-2016. | Home | Browser info | Firefox Mobile | Firefox variants | Safe surfing | Older OS

User Agent: CCBot/2.0 (http://commoncrawl.org/faq/)

Valid XHTML Valid CSS! Viewable With Any Browser

Site design and hosting by: ITWorkshop (UK) Limited | Webmaster | Privacy Policy

Browse with Firefox and Opera